Garden Tractor Forums banner
1 - 9 of 9 Posts

·
New Member
Joined
·
5 Posts
Discussion Starter · #1 ·
:wallbanging:My last Mf10 did not have a carb.
Surfed the local small engine spots, the older establishments, with no luck.
All show obsolete.

Has anyone been able to use another carb??? Other than the obsolete stock one that is.

Surely I won't have to repower, got a good free turning motor that with a little gas sprayed in
the intake hole, fires instantly. So there are two reasons not to repower, good motor and good electrics.

Thanks for the help.
 

·
Tractorholic
Joined
·
866 Posts
Yes. the Kohler will fit, but the linkage has to be rigged. Also, without really facncy work. the choke works backwards. (up is down on the dash)

Really, in a simple form, it jusy atomizes fuel... Almost anythimg "can" be modded to work.
 

·
Member
Joined
·
82 Posts
I am using a carb off of a Tecumseh 8hp on my MF 12G while I sort out the carb for the 12G. I made a spacer plate so the throttle lever would clear the block. The cables hooked up the same. It seems to be running well on the 8hp carb.
 

·
Tractorholic
Joined
·
866 Posts
Just be careful, you may be really running it lean. Running lean will make it run hot and could even sieze the motor if severe. Did you open up the fuel mixture?
 

·
Member
Joined
·
82 Posts
Yes, I was concerned about it running lean but I did richen up the mixture. I don't run it at full throttle but have enough power to do what I need to do. I just need to figure out what is wrong with the original carb. I have cleaned all the orifices several times, checked the float, jet and throttle shaft. It will run lean and then run rich. It surges constantly and will not idle. It will run with the high speed screw and idle screw adjusted all the way in. I have checked for air leaks and can not find any.
 

·
Tractorholic
Joined
·
866 Posts
Are the shafts on the butterfly's all tight and not worn out?
 

·
Member
Joined
·
82 Posts
They seem to be as tight as the shafts on other carbs that I have that run OK. I smeared grease around the shafts and that did not help.
 
1 - 9 of 9 Posts
Top