Garden Tractor Forums banner
1 - 13 of 13 Posts

·
New Member
Joined
·
53 Posts
Discussion Starter · #1 ·
Just finished the drive and was cleaning up a small area of the yard for the dogs when it just stopped moving. No forward or reverse. I am hoping it will just be a pin came out or something like that. Was getting dark and I was very cold so will have to wait for tomorrow afternoon to start looking. Any ideas where to start looking? Hope it is just on the hydro peddle or something simple. Handled the foot of snow very easily. Bryan
 

·
Registered
Joined
·
602 Posts

·
Registered
Joined
·
602 Posts
Check that you have turning belts and work toward the hydro. It may have overheated if the fins on the hydro were not cleaned out before the snow came. Check for leaky hydro lines, too.
 
  • Like
Reactions: JRJ and PappyH

·
New Member
Joined
·
53 Posts
Discussion Starter · #8 ·
Got some time today to check things out more. Found the spring that holds the idler to the drive belts had broken. Any one know where to get one? Where does it hook to? Going to be fun fixing this out in the middle of the back yard. Bryan
 

·
DR. Bolens
Joined
·
19,075 Posts

·
New Member
Joined
·
53 Posts
Discussion Starter · #10 ·
Those are a bit pricey. I went to the local hardware and got one that I hope will work. I already figured I would need to remove the battery and tray. At least it should be warmer tomorrow. Bryan
 

·
New Member
Joined
·
53 Posts
Discussion Starter · #11 ·
Well it is running again. May not be a permanent fix but good enough for now and it only cost 2 dollars. Thanks for the help, Bryan
 

·
Registered
Joined
·
773 Posts
Glad you got it going.. When I first read this thread I was curius too.. And yes I thought about the spring.. I saw the spring on mine looked like it was about to go..ON mine there's a hole on the base plate,,with a large cotter pin going thru it and spread out from underneith,, Now the eye of the cotterpin is holding the one end of the spring and the other end of spring goes to the idler.. When I first got my 1556 I saw the cotterpin looked like it was way overdue to break,,it was worn thru..so I just put another large cotterpin in there,, works fine
 
1 - 13 of 13 Posts
Top