Garden Tractor Forums banner

1 - 6 of 6 Posts

·
New Member
Joined
·
53 Posts
Discussion Starter · #1 ·
The hydrostatic seems to jump or shutter under power. What would cause this? It is full of fluid. I thought I would drain and change the fluid but can't find a drain. How do you drain the fluid? Any help is appreciated. Thanks, Bryan
 

·
Bob's Lawn and Garden LLC
Joined
·
2,183 Posts
The 1556 does not get the fluid from the rearend that uses 90 weight. The trans fluid is held in a little tank under the seat the cap is on the left side of the seat. As for draining there is no drain on it you would need to take the tank off to drain it and remove the filter. As for the shutter if the tank is full and the fluid is clean I would change the filter and see if that helps if not the pump may be going out and need some work.
 

·
Registered
Joined
·
773 Posts
The 1556 does not get the fluid from the rearend that uses 90 weight. The trans fluid is held in a little tank under the seat the cap is on the left side of the seat. As for draining there is no drain on it you would need to take the tank off to drain it and remove the filter. As for the shutter if the tank is full and the fluid is clean I would change the filter and see if that helps if not the pump may be going out and need some work.
SO Bob you saying that you cannot drain the whole system.. The tank looks like it would hold about a QT. and the filter maybe a half QT. There are 10 QTs in the whole system.. and no drain ?? Any thoughts ??
 

·
Bob's Lawn and Garden LLC
Joined
·
2,183 Posts
The rearend is a seperate part and has a different type of fluid in it. The hydro gets its fluid from the little tank up top.
 
1 - 6 of 6 Posts
Top