Garden Tractor Forums banner

1 - 14 of 14 Posts

·
Member
Joined
·
1,087 Posts
Discussion Starter · #1 ·
I'm having trouble with my latest 1650. If you hold the key on to start the engine, the breaker kicks and nothing. I've changed the breaker and still the same. I did have it running first thing today,but now it won't even try and turn over before the breaker blows. What am I missing?
 

·
Registered
Joined
·
6,076 Posts
Starter drive jammed up in the flywheel, jamming the starter ? Noel
 

·
Super Moderator
Joined
·
54,003 Posts
Sometimes, breakers can go bad and keep popping. But it usually is because something else started it all!
 

·
Member
Joined
·
1,087 Posts
Discussion Starter · #5 ·
Thanks Kenny. I put a new one on and same thing. So I put a spare I had and still the same. Has me confused.
 

·
Tractorholic
Joined
·
1,711 Posts
Check the purple wire to see if it has rubbed up against anything and is shorting out to the frame. The purple wire goes from the switch to all of the safeties and then to the stater solenoid. 1650 wiring.png
 

Attachments

·
Registered
Joined
·
6,076 Posts
Can you put 12 volt power to the starter to see if it turns. Jumper cable right from the battery. Noel

Sound like a short, some where. Key switches give trouble at times.
 
  • Like
Reactions: limebuzz

·
Tractorholic
Joined
·
8,348 Posts
Another way you could find the short would be to disconnect the purple wire at the starter solinoid if it dosent trip you found the problem,if it still trips the breaker put a test light from battery positive to purple wire you just unhooked . It should light up since there's a short, if , either start by wiggling or unpluging switches to isloate the area where the short is , could be anywhere back to the switch. If the test light didn't light up try disconnecting the purple wire at switch , like was said might be bad
 
  • Like
Reactions: limebuzz

·
Member
Joined
·
1,087 Posts
Discussion Starter · #11 ·
Thanks guys, turns out it was the seat safety bypassed but rubbing up against a hydraulic line. All fixed and running great. Graded the drive and no problems. Thanks again for all the help.
 

·
Member
Joined
·
1,087 Posts
Discussion Starter · #14 ·
Ya the set on the 1650 came from Markham area. And I have 2 sets on the one 1655
 
1 - 14 of 14 Posts
Top