Garden Tractor Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
263 Posts
Discussion Starter · #1 ·
Hi Guys,

Quick question

My 1886 has decided it wants to struggle to lift the deck esp when its hot. Been getting worse & now you have to have the engine on higher revs & the hydraulics wine quite loud

Any ideas??

Its there a valve in the block which can cause probs??

The lift cylinder is good but have a spare which has new seals which I can try but not till next week end now

Fitted new PTO belts today which has made a huge difference to the deck performance :dancingbanana:
 

·
Registered
Joined
·
9,179 Posts
I had a 1512 Cub that did the same thing. Tractor would drive OK but deck would not lift and wined a lot. Changed the filter & oil and it work great now.
 
  • Like
Reactions: WrenchinOnIt

·
Registered
Joined
·
483 Posts
I agree with him ^^^. Plugged filter would be my first thing to look at. Hopefully an easy fix. Paul
 
  • Like
Reactions: WrenchinOnIt

·
Registered
Joined
·
263 Posts
OK,

I have changed the fluid in the past few years but it has done a fair amount of mowing since

The drive still pulls well but can be jurky. (depends whos driving) :D

Sure I have a spare filter & Fluid is on the shelf.

Checked the level & it was spot on & was not dirty, but tbh you dont know till you drain it

Cant remember how mutch it holds atm but know its more than 5L??

Thanks
 

·
Got Sum
Joined
·
1,221 Posts
There is a proportioning valve on the early Eaton pumped large frames (my 1886-01's have them) in the bottom of the hydraulic lift and remotes valve (see pic), grit, dirt ? PITA to get to! As others have suggested check fluid, when was filter changed. Not to throw a wet blanket but the fact it gets worse as it heats up , heat thinning the fluid , it has been my experience the Eaton pump needs looked at internally.
 

Attachments

1 - 8 of 8 Posts
Top