Garden Tractor Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
330 Posts
Discussion Starter · #1 ·
Just got home with my newest toy, another Ridemaster. I responded to an ad for Ridemaster attachments and ended up buying all of his attachments, a spare engine, and his tractor. The tires were flat and dry rotted when I got it and he said the carb needed cleaned. I pumped up the tires at a service station on the way home and they held air. I got it running when I got home, but it runs a little rough. I will need to rebuild the carb. It was restored about 10 years ago. The colors aren't right and I will freshen up the paint in the correct colors. On the whole it is in good spade and I am very happy with the purchase. I unloaded it and put it in the barn under it's own power. On the way home we saw antiques roadshow was at the farm show complex in Harrisburg, PA. I was so tempted to swing in and see what their experts would have to say, but I just wanted to get it home. IMG_1154.JPG IMG_1155.JPG IMG_1157.JPG My son obviously approves of the new addition!
 

Attachments

·
Registered
Joined
·
1,837 Posts
Great thing besides getting it, is it should be easy to take apart!
 

·
Premium Member
Joined
·
5,740 Posts
How does the sickle bar attach to one of those?
Hangs under the front and runs off the pulley on the front of the engine.
 

·
Premium Member
Joined
·
5,740 Posts
Put in a new spark plug and adjusted the carb and got it running better. I put the discs on and disced a section of my garden before I plant. What a fun tractor to drive.
They sure are fun to drive!! Glad you got her running better.
 
  • Like
Reactions: Tbrooks

·
Registered
Joined
·
330 Posts
Discussion Starter · #10 ·
So last night when it was running, it would run smooth under load but when I put it in neutral the engine would surge or hunt. The previous owner told me before I bought it that he felt the carb needed cleaning. I decided tonight to do just that. As I was stripping it down I found the source of most of my problems, I think. It looks as though someone has had hand filed a point on the high speed jet. The point is not concentric to the shaft and the taper is not even ad has small flats on it. I had a new jet on the shelf. I am leaving it soak in carb cleaner over night and I will put it back together tomorrow and see if it will run better.
 
1 - 11 of 11 Posts
Top