Garden Tractor Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
653 Posts
Discussion Starter · #1 ·
Hi all, I'm working on an 1886 for a customer at work and after getting the problems he wanted fixed he said to service it as well. Got that all done including the hydro filter and started it up so I could check the fluid levels and noticed the hydro filter was spraying oil out pretty good. Shut it of and pulled the filter to check the gasket and it was good, figured I didn't get it tight enough and put it back on and tightened it up. Now it won't drive and when i pull the lever for the lift I can't see the rockshaft moving. Replaced the filter with another new one and it still does the same thing. When it was spraying oil out the tractor was moving but after tightening up the filter it stopped. The oil is almost full and when I press the pedal by hand I can feel a vibration and hear a slight whine as if it's trying to move but nothing happens. I have the manual for the Eaton 12 and I don't see anything in it about priming or bleeding the system. Any suggestions or ideas on where to look next? Thanks in advance. Stewart
 

·
Registered
Joined
·
197 Posts
Was going to say sounds like air in the system. Sometimes you have to cycle hydraulics a few times to expel it all. Have you replaced with correct oil? Whine is to be expected if the system is not fully filled and bled.
 

·
Premium Member
Joined
·
5,740 Posts
If its the same filter should be no problem. There air in the eaton 12 hydro bleeds them self. Sounds like you have a blockage some were.
 

·
Registered
Joined
·
653 Posts
Discussion Starter · #8 ·
I got it going again. I came back to work after supper when it was quiet and started with the basics. Pulled the drain pan out from under it that I put there to catch the oil when I changed the filter and it had a lot more oil in it than there should have been. Checked the dipstick and I guess I had a false reading before because it didn't show at all. Put 1 1/2 quarts more of atf in it and its up between the add and full marks. Started it up again pushed the pedal to go forward and about 30 seconds later I could feel resistance on the pedal and the tractor took off and goes forward and backward now. Just to answer the questions about the oil and filter it had atf in it when I changed the filter so that's what I put back in and the filter is a Cub Cadet 923-3014 hydraulic oil filter. Thanks all. Stewart
 

·
Premium Member
Joined
·
5,740 Posts
Wix 51410 is also the right filter. Sound like you letting it sit let the air come out that dropped the fluid level. Dont worry these things do whine and cry even if there full.
 
  • Like
Reactions: bprzyw and LPBolens
1 - 9 of 9 Posts
Top