Garden Tractor Forums banner
1 - 20 of 230 Posts

·
Registered
Joined
·
246 Posts
Discussion Starter · #1 ·
Hello, I did some work on a co-workers boat and in return

he wants to give me a Bolens Iseki G174 tractor. He bought

it last year to fix it up but boats are now taking his time.

The tractor will not start. It turns over but he was told the

plungers for the injectors are stuck. Also the clutch

disk is stuck to the flywheel. I have not seen it yet but the

price is right. ( free ) It has turf tires all around and a snow

blade that I am told looks unused. Any info on this

tractor or insight or thoughts would be greatly

appreciated. Thanks.
 

·
Tractorholic
Joined
·
4,070 Posts
Congrats! I was looking at one of those but the price was a bit high for me.

Being it is free you can't go wrong even if you have to buy parts for it! Not sure on the injectors. Did anyone try to bleed them yet?

We have a lot of diesel guys that can help on that.

The clutch I know on some tractors it is common for the clutch to get stuck if they sit for a long time. But I don't know what your set up is like. So i am not sure if there is a trick to getting it unstuck or if you just have to take it apart to clean things up?

No matter what you can't go wrong at that price!
 

·
Super Moderator
Joined
·
54,142 Posts
Congrats, even if is doesn't run. There's folks here to help you along. Don't know if there is a manual here for that or not. You might want to Google that engine and do a bit of reading up on it.
 

·
Registered
Joined
·
10,085 Posts
That is a very good friend to give you a very good tractor. When you get the tractor home get the service manual and go through the fuel system. Old fuel and or water can kill a diesels injectors. The first thing to check is the fuel. If in doubt drain the old fuel.

To break loose the clutch try setting the parking brake, put it in high gear, step on the clutch, and lightly touch the starter or turn the engine by wrench. This has broken loose the clutch on my Allis many times.
 

·
Accumulator
Joined
·
13,481 Posts
Man,if it's free,take it.
 

·
Registered
Joined
·
246 Posts
Discussion Starter · #7 ·
Ok, My co-work now tells me that the tractor is a tx1300 f or G154.

I wouldn't know till I actually have it home. Hopefully this weekend.
 

·
Registered
Joined
·
313 Posts
still the right price and the above comments should send you in the right direction , let me just say this for you, SCORE!!!!!!!!!!!!!!!!!! :thumbs:
 

·
Registered
Joined
·
246 Posts
Well I finally got the bolens home today. Here are a few pictures.

It is a G154. Its cool just looking at it. I have a friend that

I make parts for several of his old cars that has the car

trailer and van in these pictures that hauled the

bolens home for me today.
 

Attachments

·
Deceased
Joined
·
4,845 Posts
Now THAT is one nice looking tractor, and a HUGE score!
 

·
Tractorholic
Joined
·
8,358 Posts
Nice looking tractor even if you bought it lol Good for you
 

·
Registered
Joined
·
246 Posts
Discussion Starter · #12 ·
ITs rough and hasn't run in years but it turns over by hand.

My friend thinks the injector pump is gummed up.

The clutch disk is rusted to the flywheel also.

I'll start going through everything maybe this weekend.

Its going to take a while but hopefully I'll be able

to get it running.
 

·
Live long and prosper
Joined
·
6,786 Posts
Those compact Bolens are really nice. I love mine. Good looking one you have there. I hope you get it going in no time at all.
 

·
Registered
Joined
·
246 Posts
I was able to fiddle with the bolens for about a half an hour

tonight after work. The battery box is very rusty and bugging

the heck out of me so I removed it and the fuel tank.

I'll sand blast the battery box and the fuel tank needs

a good cleaning, It has a little rust inside.

Was the black paint used on the engine and transmission

and other parts that were painted black a gloss

or semi gloss paint? Thanks for any info.

Here are a few pictures. I used my Panzer to tow it

back to my garage.
 

Attachments

·
Registered
Joined
·
246 Posts
Discussion Starter · #18 ·
How Sweet is That!! Wow! and Congrats to you! ...Did ya bring the blade home 2 ?
I did get the blade. I actually have had the blade since christmas.

I took it al apart and sand blasted everything.

I had to make a few parts for it and I also welded

a few extra steel plates inside of the swivel frame.

I also had to make a latch to hold blade in place.

Someone had put a bolt through the plates

to keep the blade from turning
 

Attachments

·
Registered
Joined
·
246 Posts
Discussion Starter · #20 ·
Well it looks like the fuel injection pump is bad.

I've been soaking it in diesel fuel for 3 days and

I have tried to get it to pump but no good.

I have it completely submerged in fuel and when

I push down on pump air bubbles come out

around the tappets. When I take it out of

the fuel the fuel drains out the bottom of

pump around the tappets. I guess there

is some sort of seal in there that is shot.

Anyone ever have one of these pumps

apart?
 
1 - 20 of 230 Posts
Top