Garden Tractor Forums banner

1 - 11 of 11 Posts

·
DR. Bolens
Joined
·
19,060 Posts
I decided to start up my restored tractors and clean out the garage. I really dont use these tractors except for driving them at shows. The 1050, 800 and Estate Keeper haven't ran since last August , but they fired right up when I turned the key!

Here's a pic I took:

I also got the Clinton engine running in my Green Brier and will post the video here incase you missed it in the other thread.

 

Attachments

·
Premium Member
Joined
·
1,227 Posts
Nice collection Brian. Thank you for taking the time to take and post the pictures.
 

·
Live long and prosper
Joined
·
6,782 Posts
They sure look nice in the sunshine Brian. I'm glad you got the Greenbrier's Clinton going. Thanks for the video.
 

·
DR. Bolens
Joined
·
19,060 Posts
The collection looks good Brian. Congrats on getting the Green Brier running. Going to restore that one too?
Yep thats the next one in line to be restored. I planned on restoring my Husky 600 first, but the Green Brier now took its place do to its "Uniqueness" LOL
 

·
Super Moderator
Joined
·
54,000 Posts
Great herd there, even the Green Brier. Love that EK. Thanks for posting the pics!
 

·
Connoisseur of Rusty Junk
Joined
·
5,623 Posts
Great looking bunch of tractors Brian! That Clinton sounds pretty healthy too! Great job getting it running and thanks for the video!
 

·
Elf guardian
Joined
·
7,712 Posts
Thanks for shareing that Brian. Sure is a good feeling when everything fires up in the spring, isn't it.
Good looking resto's. I'm lookin forward to seeing the Green Brier al dolled up.
 
1 - 11 of 11 Posts
Top