Garden Tractor Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
557 Posts
Discussion Starter · #1 ·
Ok maybe some ideas, when the ht20 gets warmed up it dies. No spark. Changed out the coil and still have the same problem. Is there anything else that would cause this problem, maybe a condenser?
Thanks
 

·
Super Moderator
Joined
·
14,167 Posts
I'd verify the condition of all the wiring and connections in the ignition circuit. It's a good idea to do that on any older tractor. The chassis connection back to the battery is an often overlooked area where problems can come up, especially on a rubber mounted engine where a separate connection is required to make the circuit complete back to the battery - terminal. Points can do some strange things when pitted or out of adjustment. Safety switches with bad contacts, burnt, chafed, shorting or loose wires etc.
 

·
Registered
Joined
·
557 Posts
Discussion Starter · #5 ·
When it cools down it starts right up? I have a new condencer coming tomorrow. This mounts on the side of the coil. I don't think there is another one? It will be getting a tune up this summer,or maybe sooner if this new condencer doesn't fix the problem.
 

·
Registered
Joined
·
393 Posts
If you haven't changed your points yet, I would change them along with the plugs and condenser and possibly the wires. They are all fairly inexpensive but make a huge difference if already worn. I actually purchased an OEM Kohler tune up kit on ebay that included the plugs, points and condenser for under 15 shipped last year. It was an excellent investment.
 

·
Registered
Joined
·
393 Posts
I had problems with the micro switch on the PTO lever and brake too... that little switch caused me all kinds of undue stress lol.
 
1 - 7 of 7 Posts
Top