Garden Tractor Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter · #1 ·
Bought a Bolens ht20 this week with some problems but the price was right. This is my first Bolens but not my first garden tractor. Tractor has not been started in 8 years or so but the motor is not locked up. Both rear tires are rotted thru so that is my weekend goal, to get it rolling. The engine still has oil in it but looks pretty thick and black. I don't have a manual for it yet so I haven't looked at the hydraulics at all. Will try and get some pics this weekend while cleaning it up. Any advice is appreciated.
 

·
Registered
Joined
·
10,085 Posts
Once you get that running and try it out, all other GTs will seem small and weak. The Bolens LF bug got me years ago. We have an excellant shop manual for it in our Manuals Section. Good Luck, Rick
 

·
Registered
Joined
·
532 Posts
I would pull the engine tins and pull the heads off at the very least to clean and inspect the Pistons and cylinders for carbon build up, rust or any water damage from sitting. Also check the valves. I would do this before attempting to crank the engine over with a battery if it has been stored outdoors. Be sure to blow out any debris or mouse nests if it's been sitting for long.
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #5 ·
so far today i've managed to get different rear tires mounted, a pair of 12-26's I had setting around. pulled the rear pan and sprayed everything down with engine cleaner and headed to the car wash. was kind of surprised that everything on the hydrostat and rear differential was covered in grass and dirt but no oil leaking from anywhere. engine however looks like an oily dirt ball. inside of gas tank has a coating of rust in the top half and varnish in the bottom, not sure what to do with that, maybe radiator shop. tomorrow, carb goes into ultra sonic cleaner before rebuild.

thanks for the good advice on pulling the engine tins, heads, and changing oil. I usually get in a hurry and try to start something before things are back to factory specs.

list of things to order: air cleaner, points and condenser, carb kit, fuel pump is broken, battery cables have been cut off, fuel shut off for bottom of tank and fuel filter, head gaskets, spark plugs.

steering is a little loose. most of the play is in the large half gear that attaches to the drag link. needs a little machine work on pin and bushing. front axle pivot also.

will update later, thanks again.
 

·
Blackjackjakexxix
Joined
·
2,371 Posts
I agree with checking the engine tins for critters,but before you sink $$$ into it I would try to get it started even just for a few seconds,making sure it's not knocking,those fuel pumps are very pricey,just my opinion though
 

·
old member
Joined
·
417 Posts
I would pull the engine tins and pull the heads off at the very least to clean and inspect the Pistons and cylinders for carbon build up, rust or any water damage from sitting. Also check the valves. I would do this before attempting to crank the engine over with a battery if it has been stored outdoors. Be sure to blow out any debris or mouse nests if it's been sitting for long.
This is a very good suggestion as I had to do that last week to mine. There was so much carbon it had interference at TDC. This engine had set for a few years too.
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #8 ·
made a little more progress today on the ht20. carb cleaned up a little bit using HF ultrasonic cleaner. found one new battery cable to install. changed oil and filter on the kohler. couldn't wait for new parts to show, so I installed a battery just to spin it over. shot some oil in the spark plug holes so it would have some lubrication but nothing happened when I hit the key. had to chase some rusty connections behind key switch and amp gauge. second try and it spun over with oil shooting out the plug holes. oil pressure light went out after about 4 turns. next step was to check compression, 95 lbs on left side and 105 on right side, with the aid of oil in the cylinder. last thing to check before dark was if there was any spark. both plugs fire, just barely, tiny yellow spark.

thanks again for the help
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #9 ·
parts are showing up for the ht20 in my mailbox. still need to pull the tins and clean around the cylinders and top of the motor. going to pull the heads off to clean the carbon and repair one spark plug thread, probably do both spark plug holes.

started on the mower deck while waiting for parts for the motor. all 3 spindles were locked up, so new bearings to order. 2 of the pulleys are welded to the top of the shafts, so machine 3 new shafts. gear box growls pretty bad when turned and repair a few cracks in the shell. rollers are in good shape.

I will start posting pictures when I get to the machine work and restoring work.

thanks to all
 
1 - 9 of 9 Posts
Top