Garden Tractor Forums banner
1 - 16 of 16 Posts

·
Registered
Joined
·
417 Posts
Discussion Starter · #1 ·
Well, I was able to find a lift kit for my 1050. The only problem is that it is missing the two pump supports (p/n 1722345 and 1714789). Does anyone have any photos or dimensions for them?

I may end up having to fabricate them, which doesn't look like it will be too difficult.

I'll throw some pictures up tonight.

Thanks

Bob
 

·
Premium Member
Joined
·
5,740 Posts
Like to buy some? I two already made up already sitting around for my next pump that dont have them...

How far are you from me?

Elsie, Mi 48831
 

·
Registered
Joined
·
417 Posts
Discussion Starter · #3 ·
Like to buy some? I two already made up already sitting around for my next pump that dont have them...

How far are you from me?

Elsie, Mi 48831
I'm not too far away, in Belleville. Maybe an hour and a half.

I sent you a message.

Bob
 

·
Registered
Joined
·
417 Posts
Discussion Starter · #4 ·
Also, no pictures tonight, had to work late. I would have rather been messing with the tractor.
 

·
Registered
Joined
·
417 Posts
Discussion Starter · #5 ·
No pics tonight either. I forgot to take any, I was so happy to get the tractor running. I ran it out of gas the other night, and couldn't get it to run right afterwards.

I guess the fuel filter must have picked up just enough crud when I ran it dry to restrict the flow. It would start, idle ok, but as soon as I increased the rpm it would die. Took some troubleshooting tonight to figure it out. Then I got the headlights and tail lights working, and totally forgot to take any pics of the lift. Not too much to look at anyway, just a pile of parts in a box for now. It's all there except the pump supports at least, and the pump is free.

What type of oil do you guys run in the hydraulic system?

Bob
 

·
Registered
Joined
·
417 Posts
Discussion Starter · #6 ·
I finally remembered to shoot a picture. This is the lift I bought. I think it was complete except for the supports.
image.jpg

Today we took a drive to pick up the pump supports from Wilberj (thanks Jerome!) and spent some time looking at his collection. Quite impressive!

Hopefully I'll have a chance to install the lift soon, I'm thinking I may stick the engine off the 1053 on the 1050 while I'm doing that. The one on it smokes pretty badly, and I have to pull the mounting bolts to put the lift on anyway. Of course the 1053 engine needs a head gasket, but it ran good before I pulled the head.

Then I can rebuild the original engine at some point.

Here is what the 1050 looks like now with the 42" deck installed.

Bob
image.jpg
 

Attachments

·
Registered
Joined
·
417 Posts
Discussion Starter · #8 ·
Yep, thats a complete setup
May be a good idea to degrease it while you have things apart
Yep, it's a little scuzzy.

Were they originally black? I may paint it prior to putting it on too.

What type of oil/hydraulic fluid do these need?

Thanks,
Bob
 

·
DR. Bolens
Joined
·
19,076 Posts
Yep, it's a little scuzzy.

Were they originally black? I may paint it prior to putting it on too.

What type of oil/hydraulic fluid do these need?

Thanks,
Bob
Color all depended on what year they were originally installed, I have seen Gold, Cordovan (Brown) Black and Red

They just take regular 30wt Oil
 

·
Premium Member
Joined
·
5,740 Posts

·
A Little Off Plumb
Joined
·
8,018 Posts

·
Premium Member
Joined
·
5,740 Posts
1 - 16 of 16 Posts
Top