Garden Tractor Forums banner

1 - 9 of 9 Posts

·
New Member
Joined
·
6 Posts
Greetings to all Bolens owners and all tractors lovers. I first logged on back in 2010 and then had to suspend my Bolens restoration due to my wife's ill health. I did get my 1556 power washed, degreased and partially torn down. I did some wiring replacement and attempted to get the engine to turn over. When I hooked up the battery, it immediately blew the new fuse I had installed according to the wiring diagram. Apparently, I will need to do some major homework to correct this. Today, I became the proud owner of a Bolens 1600 Eliminator that actually runs great! There have been some modifications that side step a real restoration. I would be most appreciative for any direction in helping me learn about this model Bolens. Thank you! I'll get some pics on here soon!
 

·
Super Moderator
Joined
·
54,017 Posts
:ditto:Glad to see you found your way back. Be looking for more posts from you.
 

·
Tractorholic
Joined
·
255 Posts
Welcome back, I hope your wife is doing well.

I had the same problem with the fuse on my 1256 TRA12D. Turned out being a defective switch.
 

·
Accumulator
Joined
·
13,481 Posts
Welcome back guy.Sorry to hear of you wife's illness.
 

·
Senior Member
Joined
·
4,473 Posts
Welcome back kringlecarver from down here at Freedom, WI.
 

·
Connoisseur of Rusty Junk
Joined
·
5,623 Posts
Glad to have you back after so long away! Congrats on the new Bolens and good luck with the 1556!
 
1 - 9 of 9 Posts
Top