Garden Tractor Forums banner
1 - 13 of 13 Posts

·
New Member
Joined
·
370 Posts
Discussion Starter · #1 ·
My ole reliable MF 14 that has been my main mowing tractor quit on me today. This is the first MF I bought after moving to a house with a larger yard. Only issue i have ever had with the tractor has been the float in the carb sticking. Today while mowing and almost done (2 more swaths to go) the mower loaded up and the engine quit. I though maybe i had hit something in the yard to cause the deck to lock up. Engine started right back up and the deck turned on like usual but a few seconds later it did the same thing. I ended up putting in in neutral between the low and high on the rear axle so i could coast it down the hill to the house without messing up the hydro.

I pulled it in front of the garage (engine started again but there was a small knock) and pulled the engine out with my cherry picker. Once on the work table I pulled off the oil pan and found this. IMG_20180506_141637954.jpg . I pulled out the rest of the rod an piston. Crank is good to go now scoring or wear. Piston on the other hand has to be replaced due to scoring on the sides. While the engine is apart I am taking out the balance gears, they more slop on bearing than I have seen. I do not need them to go thru the block.
 

Attachments

·
Addicted
Joined
·
237 Posts
Tough start to the mowing season but it looks like you’re on a fast track to get it all fixed up.
 

·
Super Moderator
Joined
·
54,145 Posts
Not a good way to start the season! But, it'll be good for the rest when you are done!
 

·
New Member
Joined
·
370 Posts
Discussion Starter · #5 ·
An Update - The piston and rod showed up yesterday and I had the day off from one of my jobs so today was spent putting the engine back together. Everything went just fine with no major problems. The engine is in the mower and started right up and sounds good. I let it run for 15-20 minutes then went and re-torqued the head down. Tomorrow I will finish it up by bolting the grill/hood back in the mower and if no rain tonight I will be using it tomorrow to mow the lawn.
 

·
Red Tractor Nut & Diesel Addict
Joined
·
32,409 Posts
I wouldn't say it let you down, but rather it just wanted (needed) refreshing! I had a K341 in an Allis 416 lose the dipper just like yours did, but I wasn't quite as lucky, as it locked the rod just as the engine came to a stop after shutting her down, but didn't break it. My crank wasn't ruined though, and I got the aluminum off the crank journal with muriatic acid and put in a new rod. My piston was even still good, but put in a fresh set of rings.
 

·
New Member
Joined
·
370 Posts
Discussion Starter · #7 ·
olcowhand you are probably right "it wanted refreshing". It may be jealous of the other tractors I have rebuilt/restored with their new paint jobs and this one still wears its original paint.
 

·
New Member
Joined
·
370 Posts
Discussion Starter · #8 ·
It is down again :wallbanging: Put the engine back together and in the mower everything sounded good when it started up. Yesterday I went out and mowed the little bit of front yard, came to the back yard and after 2 passes I noticed there were sparks coming from out of the electric clutch area :mad2: I shut the PTO off and idle the engine down but the engine died and will not restart. I did check and I do have spark, I tried a little bit of brake clean and it wont even fire with it. The only thing I can think of is it is a timing issue. I plan on pulling the engine back out and tearing it down again.

To top things off I was using my MF10 to finish the mowing and it also quit on me and wont start. :wallbanging: I haven't checked but I think it doesn't have spark. It is one of the early 10's with the non SSI engine.
 

·
Red Tractor Nut & Diesel Addict
Joined
·
32,409 Posts
Sorry you're having a bad time with GT's lately. Seems it always comes in waves.
 

·
New Member
Joined
·
370 Posts
Discussion Starter · #10 ·
olcowhand it has been more than a wave of things breaking down lately. Along with mowers my daily driver 2011 equinox has an abs light on now after hitting a major pot hole on the interstate, most likely the front right wheel hub assembly will need replaced. I just changed out the a/c compressor, expansion valve and condenser in the vehicle today, not a fun job but at least I have a/c now.
 

·
New Member
Joined
·
370 Posts
Discussion Starter · #11 ·
An update on the engine, I found out the sparks did not come from the electric clutch. When I went to remove the head to bolt down a lift plate for my cherry picker all of the head bolts were loose. I had even re-torqued the head after it had ran awhile the first time I put it back together. When the head was taken off the head gasket had blown out and where it had blown out I noticed the block is cracked. I will get some pictures later. I did some checking around and a friend of mine had a spare parts engine. He just wants all the internal parts back along with my old block. He is going to v the crack out and use a torch to heat the block and weld it up just to have a spare engine.
 

·
Member
Joined
·
1,087 Posts
That a kick in the butt.Thankfully, you have a friend willing to swap you to keep the cost down . Good luck .
 

·
New Member
Joined
·
370 Posts
Discussion Starter · #13 ·
I just finished stripping down the engine I picked up last night. It is still a standard bore block and the replacement piston that was in cracked engine for 2 hrs is a 10 over piston. I plan on taking the block and piston in to a machine shop and have it bored to 10 over. Everything inside of this engine I picked up last night looked very good with very little wear. I did find out it also came out of a MF14, but the spec number (60221) shows it a "service engine". There are few minor differences, the dipstick bolts to the block vs coming out of the oil pan on an angle, crankshaft has a bolt to hold the flywheel vs a threaded shaft and nut, and the connecting rod having bolts vs studs and nuts.

I keep forgetting to take a picture of the cracked block.
 
1 - 13 of 13 Posts
Top