Garden Tractor Forums banner
1 - 20 of 22 Posts

·
Masseyholic
Joined
·
157 Posts
Discussion Starter · #1 ·
I'm more or less new to the forum and decided to share my next project a Massey 7 electric start, with snowblower and mowing deck

Automotive tire Vehicle Automotive lighting Motor vehicle Bumper
I bought it for $250 knowing it had a blown engine. It looks like it had been stored inside all of it's life. all the origanal tires hold air. one thing i noticed was that the shoot for the snowblower is missing haredly any pant wich means its barely been used. all the belts on the snowblower look like new too. I have completely taken the engine apart and found that the rod was wore. I have boughten a rod for it already and plan to rebuild the engine and put it back into the tractor.

One thing i noticed was the block was made of alluminum and not cast iron. is this right?

I also noticed that it has the speed rduction kit on it. Is that rare?

Is the snowblower rare? i have seen way more 10's and 12's with origanal snow blowers than i have seen 7's and 8's.

last, Did i get a good deal? I would have probaly never bought it if i didn't see the snowblower.

Thanks for any help!!
 

Attachments

·
Tractorholic
Joined
·
2,075 Posts
I'll let the Massey experts answer your questions but just wanted to say that everything looks to be in great shape. Good luck on the engine and keep us posted.
 

·
Proud to be Deplorable
Joined
·
29,904 Posts
I don't know the production #'s, but I'd say there were more 10's/12's than there were 7's/8's. Finding one with it's original snowblower in this good of condition... I'd say you did alright. Especially if the engine is savable. The 7's with gear drive would've had the vari-speed.

I think the Tec engines that were on the 7's & 8's were aluminum units. I have been told they were a lighter duty engine than the larger units.

Please continue to share pics of the restoration. I also look forward to seeing it blowing snow some day.

Thanks for sharing - Alan
 

·
Electric Tractors
Joined
·
5,639 Posts
Looks not too bad to me really good condition plus mower plus deck not bad.
MF7s came with Tecumseh H70 engines aluminum block no cast iron liner they don't last. Years ago I had a MF7Hydra and I put a new short block H70 in it and it was pretty good with the new engine. HM80 or HM100 would be the ones to put in it, these engines are bigger displacement and have cast iron liner.

MF7s and early MF8s 3 speeds, had single belt to the trany, later model 8s had 2 belts to the trany and that's were the speed reduction comes from, just reverse the center pulley and you have speed reduction.

MF7,8 snow blower being rare??? I don't really know they are around.

The ARCO Parts Books are the best source for info on these they show all the variations and changes in tractors and attachments.
 

·
Tractorholic
Joined
·
57 Posts
I have an old MF 7 with the gear reduction, I'm not sure if they were common or not. I'm going to guess that they were based on a change which was made to the earliest production tractors. The original MF 720 snow thrower ran off of the engine pulley rather than off the mule drive underneath the tractor. This type of snow thrower required the addition of 3rd extra pulley to be bolted onto the existing drive pulleys. The original MF 7's didn't come equipped with bolt holes in their drive pulleys and thus required a replacement drive pulley in order to use the snow thrower. The transition to the predrilled and tapped drive pulley happened fairly quickly (somewhere I have the production numbers of the affected tractors) and since that modification only was useful for the MF 720, I'm guessing snow thrower sales were probably fairly common. If they were common, than I think that the gear reduction accessory kits must also have been. The reduction is really mandatory for use of the snow thrower. I'm guessing the sale of the kit accompanied the sale of the snow thrower. I know that when I used to use the MF 7 for snow removal, I would typically forget to shift the drive belt when I mounted the snow thrower and quickly remembered when the first snow came. The tractor moved way too fast even in 1st gear. I would then forget to reverse the process in the spring when I mounted the mower. For some reason this wasn't as noticeable to me and I would often go for a few weeks mowing at super slow speed before I remembered. By the way, I posted the reduction kit brochure in the Massey implements section. The snow thrower you purchased is the newer style snow thrower which is much easier to mount and use than the one driven off the engine. I have both though I never use either anymore. As for price, you did fine, I actually purchased a running MF 7 with snow thrower but no mower deck for $35, however that was a while ago. Masseys didn't really command much attention in my area, most people wanted IH Cub Cadets or John Deere's, now every old Lawn/Garden tractor seems to be collectible so the prices are all much higher. As for the motors, in my area you can find H70's on older snowblowers, they typically don't have too many hours on them, but you will require an air filter assembly.
 

·
Masseyholic
Joined
·
157 Posts
Discussion Starter · #6 ·
I geatly appreaciate all the info. I will keep u guys posted and i will take pictures once i get it blowing. All i need is some govenor pieces and some gaskets and the motor is ready to go. by the time i'm done with the motor all to gether i will have about $300 into it.
 

·
Electric Tractors
Joined
·
5,639 Posts
Did some searching and NYMalloys is right on the speed reduction kit for the MF7, different setup than the MF8. Looks like all MF8 3sp had the 2 belt setup. Learn something new everyday.
 

·
Accumulator
Joined
·
13,481 Posts
That's a good looking little "7" you've got there Stoneman.
 

·
Masseyholic
Joined
·
157 Posts
Discussion Starter · #10 ·
I downloaded a 720 snow thrower manuel today and i noticed i am missing the 2 tie rods the hook up to where the blower mounts to the tractor. Are these important? What do they do? Thanks!
 

·
Red Tractor Nut & Diesel Addict
Joined
·
32,409 Posts
Not having ever owning or being around an MF7 or 8, I had to let other Massey guys answer your questions. The one I can answer....you got a good deal in my book. Nice original condition & the snowblower is in great shape as well.
 

·
Masseyholic
Joined
·
157 Posts
I got my motor all put back together but am having some problems. When i crank it over i have plenty of spark but no compression. I'm positive i put the cam in correctly, but i'm unsure if i put the valves in correctly. When i spin it over gas shoots out of the carb and when i turn the coke on it gives it enough compressin to make it ''pop'' a little. I appreciate any suggestions
 

·
Proud to be Deplorable
Joined
·
29,904 Posts
Better stop rolling it over till you find this.
It sure does sound like the cam is off time.
I'd start by taking the breather off & watching the valves. Check for gap on the valves. Then you may have to pull the head & watch stuff to see where the problem may be.
 

·
Masseyholic
Joined
·
157 Posts
Discussion Starter · #14 ·
Thanks for the help! it turns out i had the valves mixed up. it runs awsome but it seems that the govoner doesn't work. when i throttle up it slowly starts to rev way high and i have to watch it when i blow with it. thanks again for the help! I'll get pictures later
 

·
Proud to be Deplorable
Joined
·
29,904 Posts
From what I remember, the gov arm is pretty easy to get flipped over... Then it won't do anything.
I'm also wondering if the gov gear is where it should be/little cap that moves missing. Was someone else in it before you were? Better look thru the "extra" parts box & see if anything gov parts-related is in the bottom. Pretty sure there is an exploded view in the manuals section, might look it over.
 

·
Masseyholic
Joined
·
157 Posts
Discussion Starter · #16 ·
Ya, it looked like someone had rplaced the rod before i did. the govoner gear had no theeth on it when i first took the enginge aparp. it looked like it had over reved. i put it back together the way i took it apart, and i don't remember seeing any "cap". Thanks for the help!!
 

·
Masseyholic
Joined
·
157 Posts
Discussion Starter · #19 ·
Well it turns out that the bolt at the base of the govenor arm was loose! after tightening it up it seems to run fine! But after it sitting over the week i went to start it yesterday and it ran like crap :wallbanging:. So i tried swapping and cleaning carbs to no solution. Then I took the spark plug out and watched the spark and about every 5 seconds or so it would ''skip a beat''. Could my condensor be shot? Points? I tried numorous spark plugs but got the same problem, Thanks for any help.
 
1 - 20 of 22 Posts
Top