Garden Tractor Forums banner
1 - 12 of 12 Posts

·
Tractorholic
Joined
·
3,097 Posts
bjenner, Welcome to GTTalk, glad you stopped in. How about more information about what WAS working about the snowblower? Do you know if the belt started slipping at the PTO? Did the belt run good, but maybe the auger didn't?
 

·
Premium Member
Joined
·
1,616 Posts
I see that your in Merritt B.C. when you say it won't throw the snow I can probably say that the snow was way to heavy and wet.Isn't that usually the type of snow you get in Merritt ?? Seeing that it's just single stage it's going to plug up very easy.A two stage snowblower in heavy wet snow will plug up also if your feeding the blower to fast.One thing about the single stage is that your going to have to keep your RPMs up if the snow is wet and go into it slowly.If its to wet and heavy its just not going to blow the snow. Even being in Manitoba if the snow is wet/heavy the blowers do like to plug up.
 

·
Tractorholic
Joined
·
3,097 Posts
Also, not that I know from personal experience, don't keep your blower in a heated garage and then just start blowing snow. Warm metal, snow, freezing temps mean snow that turns to water and back to ice.
 

·
Tractorholic
Joined
·
866 Posts
Yea, I mean, it's a pretty simple set up... It's all chain drive from the pulley jack-shaft, so I am guessing belt tension, or really wet snow!
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top