Garden Tractor Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
416 Posts
Discussion Starter · #1 ·
Still working on the MF16 when I get time. Its much closer to running. I have looked through the manuals but could not see where the negative battery cable is supposed to attach to the chassis. I used a longer bolt and placed the cable between two nuts but I really don't like mounting anything too snugly on the plastic dash. The only other spot where I could see that it may have mounted would be the bolt at the base of the center support (to which the solenoid mounts).

DSCN7030.JPG

DSCN7032.JPG

DSCN7033.JPG

Maybe it should mount to this bolt near the column?

DSCN7035.JPG

Also there is a small ground strap for the engine. I have been told it mounts to a hole in the frame but I'm not seeing a hole other than the one the running board mounts to on the RH side of the frame. The other side mounts to the RH front engine mounting bolt I believe.

DSCN7037.JPG

Thank you for any information!
 

Attachments

·
Registered
Joined
·
915 Posts
I have 3 MF 14's

Not sure on proper spot but you are close compared to the MF 14

The ground does bolt under the dash like you have but not on the dash where you have it

Unfortunately the tractors are not at my apt

The MF 16 could be different since the engine is rubber mounted

Hopefully someone with a MF 16 can chime in to enlighten us
 

·
Electric Tractors
Joined
·
5,639 Posts
The last pic with the longer bolt in the frame by the engine is where a jumper strap goes to connect the ground of the engine to the frame.

The battery ground goes right to the block of the engine.

That's how mine were wired.
 

·
Registered
Joined
·
36 Posts
Still working on the MF16 when I get time. Its much closer to running. I have looked through the manuals but could not see where the negative battery cable is supposed to attach to the chassis. I used a longer bolt and placed the cable between two nuts but I really don't like mounting anything too snugly on the plastic dash. The only other spot where I could see that it may have mounted would be the bolt at the base of the center support (to which the solenoid mounts).

DSCN7030.JPG

DSCN7032.JPG

DSCN7033.JPG

Maybe it should mount to this bolt near the column?

DSCN7035.JPG

Also there is a small ground strap for the engine. I have been told it mounts to a hole in the frame but I'm not seeing a hole other than the one the running board mounts to on the RH side of the frame. The other side mounts to the RH front engine mounting bolt I believe.

DSCN7037.JPG

Thank you for any information!
 

·
Registered
Joined
·
36 Posts
Your negative ground is in the correct place according to your picture and the engine ground mounts to the block wrapping around the mounting plate to the underside of the frame using the same bolt
 

·
Registered
Joined
·
416 Posts
Discussion Starter · #9 ·
Your negative ground is in the correct place according to your picture and the engine ground mounts to the block wrapping around the mounting plate to the underside of the frame using the same bolt
Thank You. I think I will try to button it up this weekend!
 
1 - 9 of 9 Posts
Top