Garden Tractor Forums banner
1 - 11 of 11 Posts

·
Member
Joined
·
202 Posts
Discussion Starter · #1 ·
A few weeks back I attacked this pile of rubble on the side of my shed which was 2 MF12H tractors in various states of destroyed. These 2 gems:rolling:layed around for 2 years before I got to them. I was a pretty involved parts swap. The "parts tractor" had a better frame than the one the guy had started to fix up so it took a little time. From those 2 I have built 1 which will eventually do most of the mowing and be the wife's machine. The HH120 mystery meat motor rumbled back from an unknown length hibernation yesterday on some carb cleaner:bounce:.

The tractor is getting closer to moving but, I could sure use a good reservoir for the Hydra Speed. Mine could be fixed but lot of other things are eating up my time as well.
 

·
Member
Joined
·
202 Posts
Discussion Starter · #2 ·
Today, I got the carb rebuilt, amongst other duties around the shop. I had a little spare time to try my hand at silver soldering the little foam line fittings back on the tank. I didn't do too bad, hopefully it doesn't leak.

Looks like the original lines on the tank were clear vinyl hose? Any better suggestions, I don't really like leaks.
 

·
Tractorholic
Joined
·
866 Posts
I had to solder my lines back on too. The clear line should be some fuel line for small stuff like weed eaters and the like.
 

·
Member
Joined
·
202 Posts
Discussion Starter · #6 ·
It runs, it runs, it runs. I put the carb on and it pretty much fired right up and ran. I ran it for 1 1/2 hours at varying speeds and it never spit out any parts. I can't believe that I gambled and won. Now to bring the Hydra Speed back online.
 

·
Super Moderator
Joined
·
54,355 Posts
That's great news! Now, get back to work!:bigrofl:
 

·
Tractorholic
Joined
·
428 Posts
[quote name='MF10 DIESEL']It runs, it runs, it runs. I put the carb on and it pretty much fired right up and ran...and it never spit out any parts. QUOTE]
Thats always a good sign, and an optimistic quote to boot!:bigrofl:
btw, did you recieve the dash tower i sent you? Ive all but forgotten about it since it shipped.
 

·
Member
Joined
·
202 Posts
Discussion Starter · #10 ·
fordmustang1984 said:
MF10 DIESEL said:
It runs, it runs, it runs. I put the carb on and it pretty much fired right up and ran...and it never spit out any parts. QUOTE]
Thats always a good sign, and an optimistic quote to boot!:bigrofl:
btw, did you recieve the dash tower i sent you? Ive all but forgotten about it since it shipped.
I did get it, just haven't got it on yet. I did some measuring and the starter solenoid on the Lister Petter is going to be scary close. The mowing season is drawing to a close, so I should have some time to get around to attempting a fit. That little tractor is starting to get so jam packed with parts it's starting to look like a new front wheel drive car!
 
1 - 11 of 11 Posts
Top