Garden Tractor Forums banner
1 - 10 of 10 Posts

·
Premium Member
Joined
·
1,227 Posts
Today I pulled the engine shroud off in search of the ignition module so I can install the toggle switch as a kill switch. I got the cover off, and still nothing. So I proceded to remove the flywheel. STILL NO IGNITION MODULE! Am I stupid or something? This is a Wisconsin TRA-12D engine. It has no points, it is a solid state engine. Though I do have spark. Here are the pictures. Note: the stator plate says syncromag
dscn2794.jpg http://gardentractortalk.com/gallery/files/4/4/7/dscn2794.jpg

dscn2793.jpg
http://gardentractortalk.com/gallery/files/4/4/7/dscn2793.jpg
dscn2792.jpg
http://gardentractortalk.com/gallery/files/4/4/7/dscn2792.jpg
 

Attachments

·
Premium Member
Joined
·
1,227 Posts
Discussion Starter · #2 ·
I put everything back together, and got it running. The engine seems to run fine except that it started running very hot in a short period of time. I put a brand new muffler on it which was painted silver, and after about 3 minutes its golden brown. The top of the head was also slightly smoking.
 

·
DR. Bolens
Joined
·
19,076 Posts
First time I ever seen something like that before. Almost looks half homemade.

No wonder why it was so confusing when we were e-mailing back and forth. You have a totally different setup than what I've seen.
Its normal for the coating on the new muffler to darken and smoke in a few minutes time.
You may have got some grease around the head while you were working on it that was probably burning off
glad to hear you got her running!
 

·
Premium Member
Joined
·
1,227 Posts
Discussion Starter · #4 ·
I took the main jet out and cleaned it. Upon taking it out I noticed it was in almost all the way. So I thought I found the problem. I took it out for another spin and again, she got real hot.
Is this ignition something from Overnight Solutions? I dont understand how the coil gets power. The stator plate has a wire running to the + side of the coil and thats it.
 

·
Red Tractor Nut & Diesel Addict
Joined
·
32,409 Posts
The module is the long curved section to the right of the stator coils. One piece system...no replacing just the module.
So is this using an automotive type coil? What connects to the negative side of coil?
 

·
Premium Member
Joined
·
1,227 Posts
Discussion Starter · #6 ·
Is this original for the TRA-12d engine? The negative side goes to ground
 

·
DR. Bolens
Joined
·
19,076 Posts
bread320i said:
Is this original for the TRA-12d engine? The negative side goes to ground
Adam I've seen about 7 TRA-12D's over the years and none of them looked like that. They all had the stator plate behind the flywheel and the module mounted to the front of the shroud.
 

·
Red Tractor Nut & Diesel Addict
Joined
·
32,409 Posts
bread320i said:
Is this original for the TRA-12d engine? The negative side goes to ground
I have no idea if it's OE. never had or worked on a 12....no books on one either. Sounds like it you ran that ground to your toggle, when the switch broke the ground, it should kill the engine.
 

·
Premium Member
Joined
·
1,227 Posts
Discussion Starter · #9 ·
I spent aboout 15 minutes driving this tractor around today. The longest Ive ever spent on this tractor. I was having issues with it running hot. So I cleaned the carb which didnt help. Today I removed the head and cleaned all the carbon and lapped the valves. Removed the new muffler that I had on there and it ran great. I beleive the muffler was to restrictive and holding back to much heat.
Im really glad to have this tractor running the way it should.
 
1 - 10 of 10 Posts
Top